It is currently Mon Oct 21, 2019 10:18 am

All times are UTC + 10 hours




Post new topic Reply to topic  [ 16 posts ] 
Author Message
 Post subject: Flat battery unexpectedly on New Swift
PostPosted: Thu Oct 08, 2009 5:51 pm 
Offline

Joined: Wed Aug 19, 2009 9:13 pm
Posts: 26
Location: Sydney
After having a new Swift for less than 6 weeks, this morning, the battery was flat. All doors were closed. Interior lights were set to Door. So the problem was not caused by leaving something on or open.

The battery is one of the newer kind (calcium) and is sealed.

Has anyone else had this kind of battery problem before? Is it a warranty issue? (I seem to remember that when we first got the car the battery did not show "green" on the indicator for fully charged.

I understand the old "normal" (for lead/acid) battery chargers can only charge these new batteries up to about 60% of their total charge? Is this true?
Thankyou
JB


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Fri Oct 09, 2009 6:32 am 
Offline

Joined: Wed Aug 19, 2009 9:13 pm
Posts: 26
Location: Sydney
Anyone?
ta


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Fri Oct 09, 2009 7:31 am 
Offline
User avatar

Joined: Sun Dec 23, 2007 7:12 pm
Posts: 221
Location: Sydney - North
highly doubt you'll get anything out of warranty.
It'd be like claiming petrol under warranty.

Charge it up and go, the best you can do.


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Fri Oct 09, 2009 8:13 am 
Offline

Joined: Wed Aug 19, 2009 9:13 pm
Posts: 26
Location: Sydney
thx 4 that.
I thought I would get NRMA to make an assessment (as well a jumper the car to start it). That way I can be more confident with the dealer.

Having said that, Do the new Swift's definitely have Calcium batteries? How can I tell...the manual says nothing about the battery type. And the battery has Japenese or Korean all over it.
And what charger should I get? Brand names?
thx,
JB


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Fri Oct 09, 2009 9:45 am 
Offline
User avatar

Joined: Mon Oct 18, 2004 8:54 pm
Posts: 7414
Location: Adelaide SA
Best to just give it a charge and see how it goes. If it still acts up.. THEN contact suzuki

If you have to buy a charge any Supercheap will help you out. you dont need to most expensive one there either to simply charge a battery

_________________
CJ Performance "Specialising in ECU Modification and Performance"

Offical 2006 RedlineGTi Paper, Scissors, Rock Champion!!


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Fri Oct 09, 2009 10:25 am 
Offline

Joined: Wed Aug 19, 2009 9:13 pm
Posts: 26
Location: Sydney
Thx for the advice..Shall try that and let u know what happens....
JB


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Mon Jun 07, 2010 4:35 pm 
Offline
User avatar

Joined: Fri Nov 27, 2009 7:17 am
Posts: 136
Location: Sydney
Gonna dredge this post up as I had a flat battery on Sunday in a 8 month old Swift Sport. NRMA had to jump start it for me.

Was told by the NRMA that a common reason for a relatively new battery, to go flat so quickly, is if you are doing short trips on a regular basis. The reasoning behind this is that it takes a large amount of the electricity in the battery to start the motor. This charge then needs to be replaced. While the engine is running the alternator charges the battery back up again (I know nothing new here!). To fully charge it back up though, I was told it takes a run of about an hour. Unfortunately with short trips (15mins) to and from work, the charging time is not enough to fully charge it back up again. You park and stop the engine, start it up to go home and repeat the process over and over. After a few months of this the maximum charge held in the battery drops to the point that it does not hold enough charge to start the motor.

After the jump start, NRMA told me to run the engine for an hour straight and I should be right for another 3 months or so. Or buy a battery charger and charge it every 6 months or so.

Now the issue I have with this explanation is that I have done long drives to Griffith and back on average once a month since January. Also runs to Penrith from the city as well. I thought that these long drives would be sufficient to fully charge the battery back up to the top of the charge cycle with the maximum charge available again.

I rang Suzuki and explained the situation to them. They said it should not be having an issue after only 8 months, even with short trips and to bring it in to be tested and checked.


Would welcome anyone with similar experience or knowledge on this to share???


FYI - to bradje if you still read the posts - the green indicator is a float level, in one chamber of the battery and indicates the level of fluid between the plates in that chamber of the battery. It turns black or yellow when the fluid level drops and indicates the need to top up with deminerilised water or replace the battery.....

_________________
Swift Sport '09
Champion Yellow


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Mon Jun 07, 2010 4:56 pm 
Offline
Moderator
User avatar

Joined: Mon Aug 25, 2003 12:00 am
Posts: 17558
Location: ACT
If your battery is serviceable then get some Inox battery conditioner and use it as per instructions. Premature lead-acid battery "death" is usually only caused by calcification. I have used Inox for years on batteries that had run flat, and extended the life of some by up to 2 years. Great stuff for around $10 a bottle.

_________________
Suzuki MightyBoy - Three pots and a snail.


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Mon Jun 07, 2010 7:53 pm 
Offline

Joined: Wed Aug 19, 2009 9:13 pm
Posts: 26
Location: Sydney
Hi RS416,
I found that the ignition switch was sometimes not being turned off fully (I blame it on my wifey :shock: ).
Since we did a check, each time we exited the car to make sure it was fully off, we have never had another problem.
The 2 or 3 times it happened, it seemed like everything was off, but when checked, the ignition switch was one click forward!! (We have one of those fob things that allows us not to use a key at all).

Also, btw, I did use a "normal" old-style charger overnight to recharge the battery (disconnected from the car of-course) and the battery would charge back OK no probs.
My wife drives the car and only does very short trips...never more than 10K's. And there have been no more problems. The battery is always "green" now.
Cheers,
JB


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Mon Jun 07, 2010 9:41 pm 
Offline
User avatar

Joined: Fri Nov 27, 2009 7:17 am
Posts: 136
Location: Sydney
Thanks for quick response JB! I can't remove the key without turning it off fully so that rules that one out. Good to know though as it leads me to believe that the battery might just be a bit off.

Will see what Suzi dealer says on Friday and let ya know!

Thanks for the tip on the Inox too, if they say nothing is wrong with it I'll give it a go!

cheers,

_________________
Swift Sport '09
Champion Yellow


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Tue Jun 08, 2010 6:24 pm 
Offline

Joined: Wed Aug 19, 2009 9:13 pm
Posts: 26
Location: Sydney
I'm supposing that your battery is sealed like mine, so you can't add water to it, or is that not the case?
Is your battery showing "Green" on its indicator now after the NRMA visit?
Are the fluid levels Ok in the battery?
Cheers,
JB


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Tue Jun 08, 2010 10:03 pm 
Offline
User avatar

Joined: Fri Nov 27, 2009 7:17 am
Posts: 136
Location: Sydney
It is a sealed "maintenance" free battery and the green float was showing green before during and after the NRMA visit. It just didn't have enough residual charge to start the motor.

Those float level green indicators can be misleading as well as they only show the fluid level in one chamber I believe and do not necessary inidicate that all chambers are okay, if that makes sense...

Still starting three days after the jumpstart and running the engine for 1 hour afterwards. Will see what Suzi says and let ya know!

cheers!

_________________
Swift Sport '09
Champion Yellow


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Wed Jun 09, 2010 3:40 pm 
Offline

Joined: Wed Aug 19, 2009 9:13 pm
Posts: 26
Location: Sydney
Yes, interesting....u should be able to see the fluid level by rocking the car a bit....Do all the chambers look full?
It will be interesting to see if Suzuki will do anything.....
Cheers,
JB


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Tue Jun 15, 2010 8:05 am 
Offline
User avatar

Joined: Fri Nov 27, 2009 7:17 am
Posts: 136
Location: Sydney
Took the car into the Suzi dealer and they could not find any fault with the battery or the charging system. No surprises there.

Perhaps the NRMA tech who jump started the car was correct in his analysis. Numerous short runs over a period of 6 months or so drain the battery enough, without ever fully charging it, to lower the maximum charge held sufficiently to not have enough charge to start the engine at some point.

I ran a battery charger on the weekend and it only took 10 minutes to reach full charge and cut out, so didn't seem to require much. My mate who has an 18 month old Mini Cooper ran the charge on his battery and it took 30 minutes before cutting off, which surprised him as he drives much further than I dod on a daily basis. All depends on driving habits I guess and what accessories you run plus driving time between engine start and stops.

Will now be investigating a battery charger and running it once a month to keep the battery at maximum charge. Seems to be recommended by some battery manufacturers as well.

_________________
Swift Sport '09
Champion Yellow


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Thu Sep 29, 2011 8:18 pm 
Offline

Joined: Wed Aug 19, 2009 9:13 pm
Posts: 26
Location: Sydney
Wasn't turning off the ignition correctly.
told ya I would tell you what happend....1 year late though!! #-o
JB


Top
 Profile  
 
 Post subject: Re: Flat battery unexpectedly on New Swift
PostPosted: Thu Feb 07, 2019 6:27 pm 
Offline

Joined: Thu Feb 07, 2019 6:24 pm
Posts: 1
Location: UK
I always have an Energic Plus jump starter in the back of my car!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: Google [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © phpBB Group