It is currently Tue Dec 19, 2017 12:50 am

All times are UTC + 10 hours




Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: car wont start ,injectors seem not to be firing
PostPosted: Wed Nov 15, 2017 2:32 pm 
Offline

Joined: Sun Nov 29, 2015 12:01 pm
Posts: 8
Location: Barbados
Check for spark which is there.
Fuel pump cuts in and fuel is at the rail.
tried two different ecu's same problem occurs but it 12volts is ran directly to the injectors the injectors spray and car is able to start and run once the direct 12 volts is removed car wont run or even start


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Wed Nov 15, 2017 3:08 pm 
Offline
User avatar

Joined: Wed Feb 22, 2006 5:19 pm
Posts: 1983
Location: Launceston, Tasmania
Sounds like you have an engine immobilser kicking in. The last car I bought had the same problem at the dealer and they nearly removed the entire fuel system to find the fault before they realised they just needed the security coded key.

_________________
Back in the game! Now building something mental... Will I ever finish? I hope so! When? No idea.


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Thu Nov 16, 2017 2:31 pm 
Offline

Joined: Sun Nov 29, 2015 12:01 pm
Posts: 8
Location: Barbados
Check for immobiliser and car carrries none
Engine harness had burn and was replaced along with coil,ecu, and igniter


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Mon Nov 20, 2017 2:36 pm 
Offline
User avatar

Joined: Mon Aug 25, 2003 12:00 am
Posts: 1665
Location: Adelaide
check the dizzy, that is what feeds the signal to the ECU to fire the injectors.
Does the fuel pump stay on while cranking or does it just prime on ignition on?

_________________
IPRA MK3 Gti ~ Mallala 19/11/11 1:23.5915
Sponsored by
Autosport ~ Velo Seats ~ Morpowa Dyno Centre ~ Diamond Concrete Finishers & Polishers


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Wed Nov 29, 2017 6:31 am 
Offline

Joined: Thu Apr 21, 2016 11:00 am
Posts: 58
Location: Aus
Check your ignition fuse under the dash


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Sun Dec 03, 2017 11:23 pm 
Offline

Joined: Sun Nov 29, 2015 12:01 pm
Posts: 8
Location: Barbados
moylee19 wrote:
check the dizzy, that is what feeds the signal to the ECU to fire the injectors.
Does the fuel pump stay on while cranking or does it just prime on ignition on?

Sounds like it just primes on ignition


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Mon Dec 04, 2017 2:58 pm 
Offline
User avatar

Joined: Mon Aug 25, 2003 12:00 am
Posts: 1665
Location: Adelaide
could be a stuffed trigger in the Dizzy. Have seen it before. Can you get another one to test.

_________________
IPRA MK3 Gti ~ Mallala 19/11/11 1:23.5915
Sponsored by
Autosport ~ Velo Seats ~ Morpowa Dyno Centre ~ Diamond Concrete Finishers & Polishers


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Tue Dec 05, 2017 1:27 am 
Offline

Joined: Sun Nov 29, 2015 12:01 pm
Posts: 8
Location: Barbados
moylee19 wrote:
could be a stuffed trigger in the Dizzy. Have seen it before. Can you get another one to test.

Change dizzy still the same . Could it be injector grounds to back of intake ?


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Tue Dec 05, 2017 12:42 pm 
Offline
User avatar

Joined: Tue Feb 23, 2016 5:38 am
Posts: 141
Location: Amberley
Check your water temp sensor and air flow sensor as per the manual. Are you getting any diagnostic codes? If you crank the car for 2 seconds and then put a fuse in the diagnostics pin without turning the ignition off is there a code flashed.


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Tue Dec 05, 2017 6:16 pm 
Offline
User avatar

Joined: Thu May 13, 2004 7:03 pm
Posts: 3243
Location: Brisbane
check you have ignition signal from the brown of the noise suppressor back to a12 of the ecu.

_________________
Dr Suzuki - Mobile Suzuki specialist mechanic
www.facebook.com/suzukimechanic for contact details or to like/share my page.


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Wed Dec 06, 2017 9:39 pm 
Offline

Joined: Fri Oct 10, 2014 4:53 am
Posts: 70
Location: Portugal
Try to disconnect the tps and see if it starts


Top
 Profile  
 
 Post subject: Re: car wont start ,injectors seem not to be firing
PostPosted: Sun Dec 10, 2017 1:04 am 
Offline

Joined: Sun Nov 29, 2015 12:01 pm
Posts: 8
Location: Barbados
Unplug tps still no change .Probe plug c2,c7 at ecu receiving 12volts which is injector power source. When injector wires probe at connector no voltage with would be c3,c4 injector positive and c8,c9 injector negative at ecu


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © phpBB Group