It is currently Fri Nov 24, 2017 9:24 pm

All times are UTC + 10 hours




Post new topic Reply to topic  [ 48 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: Before and after pic of engine
PostPosted: Tue Oct 27, 2009 6:59 pm 
Offline

Joined: Tue Feb 03, 2009 9:54 pm
Posts: 113
Location: townsville
its ok for the price i spose. havent run it yet so soon will see...


got spark today woohoo.


Top
 Profile  
 
 Post subject: Re: Before and after pic of engine
PostPosted: Tue Oct 27, 2009 8:20 pm 
Offline
User avatar

Joined: Mon Aug 25, 2003 12:00 am
Posts: 6838
Location: Brisbane
My luck to you mate its looking good.

I would be interested to see the flow rates between that intercooler and an unmodded one but I seriously doubt that will be a major issue with a low boost system.

_________________
Issue 42 http://www.ssgti.net/fastb.htm

YOU want to PLAY, YOU got to PAY .. Performance doesn't come cheap


Top
 Profile  
 
 Post subject: Re: Before and after pic of engine
PostPosted: Tue Oct 27, 2009 9:43 pm 
Offline

Joined: Tue Feb 03, 2009 9:54 pm
Posts: 113
Location: townsville
i cant imagine there being too big an impact. at the end of the day its a run around car anyways. i will be re routing the intercooler pipe from the turbo to the intercooler as my front bar doesnt fit now


Top
 Profile  
 
 Post subject: Re: Before and after pic of engine
PostPosted: Wed Oct 28, 2009 4:11 pm 
Offline

Joined: Tue Feb 03, 2009 9:54 pm
Posts: 113
Location: townsville
took it for its first spin today. unfortunatelly the turbo chip i recieved when i purchased the turbo kit is faulty so only runs with standard chip.

with turbo chip engine was hunting on idle and was missig constantly thorugh rev range, couldnt get passed 3000rpm


Top
 Profile  
 
 Post subject: Re: Before and after pic of engine
PostPosted: Wed Oct 28, 2009 11:01 pm 
Offline
User avatar

Joined: Thu Sep 25, 2008 11:38 pm
Posts: 2053
Location: adelaide
patskies wrote:
took it for its first spin today. unfortunatelly the turbo chip i recieved when i purchased the turbo kit is faulty so only runs with standard chip.

with turbo chip engine was hunting on idle and was missig constantly thorugh rev range, couldnt get passed 3000rpm

i had the same problem when i received my turbo chipped ecu with the turbo kit i bought from the same guy.
you where probably given the same ecu as i sent it back to him

_________________
"I don't try to explain to people why I drive a GTI. For those who understand no explanation is needed! For those who don't understand, no explanation is possible..." ghostG13B

Bewitched Performance Crew


Top
 Profile  
 
 Post subject: Re: Before and after pic of engine
PostPosted: Thu Nov 05, 2009 7:56 pm 
Offline

Joined: Tue Feb 03, 2009 9:54 pm
Posts: 113
Location: townsville
got the new turbo chip and threw it in yesterday. going to wait til my new exhaust comes in the freight before i drive it. atm there is no exhaust after the dump pipe.

also want to get a standard dash and door trims.

and looking at getting boost, oil press, oil temp and coolant temp gauges. any recommendations?


Top
 Profile  
 
 Post subject: Re: Before and after pic of engine
PostPosted: Fri Nov 06, 2009 2:36 am 
Offline

Joined: Tue May 13, 2008 6:38 pm
Posts: 72
Location: Perth
patskies wrote:
got the new turbo chip and threw it in yesterday. going to wait til my new exhaust comes in the freight before i drive it. atm there is no exhaust after the dump pipe.

also want to get a standard dash and door trims.

and looking at getting boost, oil press, oil temp and coolant temp gauges. any recommendations?


Personally I really like the Venom gauges, the style of them and how they light up just looks really nice, though it comes down to interior scheming ultimately.


Top
 Profile  
 
 Post subject: Re: Before and after pic of engine
PostPosted: Mon Nov 23, 2009 2:11 pm 
Offline
User avatar

Joined: Thu Apr 12, 2007 12:24 pm
Posts: 501
Location: gosford
the ecu you sent back is in the mini {sorry g13b turbo powered mini } and going fine
thx
jason
ghostG13B wrote:
patskies wrote:
took it for its first spin today. unfortunatelly the turbo chip i recieved when i purchased the turbo kit is faulty so only runs with standard chip.

with turbo chip engine was hunting on idle and was missig constantly thorugh rev range, couldnt get passed 3000rpm

i had the same problem when i received my turbo chipped ecu with the turbo kit i bought from the same guy.
you where probably given the same ecu as i sent it back to him

_________________
GTiTEC
image_id: 12024
1600cc AWD
http://www.youtube.com/results?search_q ... tec13&aq=f
turbos kits,braces,intakes,rollcages and all mods


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 48 posts ]  Go to page Previous  1, 2, 3

All times are UTC + 10 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © phpBB Group